chat function partially not available

Minor incident Live Chat
2023-02-15 10:22 CEST · 1 day, 4 hours, 3 minutes

Updates

Resolved

We were able to correct the fault.

February 16, 2023 · 14:25 CEST
Investigating

Live chat is currently unavailable for some customers; we ask you to contact us by phone until the issue is resolved. Thank you

February 15, 2023 · 11:10 CEST

← Back