Billing and store orders not available

Minor incident Internal administration sofware
2023-02-22 10:06 CEST · 1 hour

Updates

Resolved

The disruption has been resolved, but we continue to monitor the situation. Of course, we apologize for the circumstances that have arisen.

February 22, 2023 · 11:07 CEST
Investigating

Billing and store orders are currently unavailable due to an outage at our Subscription Management partner. We are monitoring the issue and will provide an update once our partner has resolved the issue.

February 22, 2023 · 10:11 CEST

← Back