Issues with our telephone support

Major incident Desktop applications iOS Application Android Application Push Notifications API Print Service POS System Administration
2020-08-30 13:00 CET · 1 hour, 34 minutes, 8 seconds

Updates

Resolved

The issue appears to be resolved

August 30, 2020 · 14:34 CET
Issue

Currently merchants might experience issues reaching us by telephone. We are working on the problems with our vendor.

August 30, 2020 · 13:48 CET

← Back