readyPay: Crashes during payments requiring PIN entry
Minor incident
Cash register
2026-08-18 09:00 CEST
· 1 day, 2 hours, 42 minutes
Updates
Resolved
August 18, 2026 · 16:40 CEST
The cause has been fixed and payments with PIN entry are working normally again. On individual devices the different design may persist for up to 48 hours – functionality is not affected.
Issue
August 18, 2026 · 14:40 CEST
For readyPay payments that require PIN entry (especially for larger amounts), readyGo, readyMini, and readyTab may currently experience crashes. If this happens, please restart the terminal twice. Payments should then work again. The terminal may temporarily appear with a different design; this will be reverted with a subsequent update.
← Back